goznayr

Voicemail Is Kicking In Too Fast

Recommended Posts

Hi Guys,


 


Almost everyone on our Swyx 2015 server is experiencing their voicemail kicking in far too fast.


 


I have changed the "Call Forwarding No Reply" delay from 15 seconds to 60 seconds yet the voicemail still kicks in at aroun 5 or 6 seconds.


 


There are no Pre or Post Processing scripts either.  Am I missing something?


 


Any help would be appreciated.


 


Thank you


Richard Gosnay


Share this post


Link to post
Share on other sites

When any phone device (SwyxIT, Mobile, Landline) calls a Swyx account whether via DDI or Extension, the voicemail kicks in rather quickly, and this applies to probably 90% of our users.


 


Bit more background - We had Swyxware 2013 installed on our old server and because the CPU/Memory was quite old, the IpPbxSvr was struggling so the one ring (quick voicemail) thing started popping up on a couple of accounts.  Because of this, we have now upgraded to Swyxware 2015 on a brand new server, the CPU hovers around 5% and we're only using 3.5Gb of the allocated 8Gb.


 


There did used to be a rulePreProcessing.vbs file that allowed me to block specific numbers but I removed it in case that was affecting it.  I've done everything by the book and yet the problem remains, the only thing left to do is create a brand new install and add each user, script, skin, DDI individually which I'd rather avoid.


 


Any suggestions?


Share this post


Link to post
Share on other sites

Do you have any special call routing on the users (except the disabled pre-processing) ?


 


Actually I can't think of anything that would start the voicemail that early.


Share this post


Link to post
Share on other sites

No what so ever, I have just tried disabling the voicemail and after roughly 8 seconds the call just cuts off.  I tried another extension with disabled voicemail, that cut off after 4 seconds.


 


I am seriously confused!!!


Share this post


Link to post
Share on other sites

Is there a way to enable a full trace on a specific trunk or extension so I can try and pinpoint where the issue kicks in?


Share this post


Link to post
Share on other sites

If you haven't explicitly disabled tracing the standard tracing is enabled. What you would need is the server trace which can be found in the file ipbbxsrv_xxx.log in the Swyx trace folder.


 


C:\ProgramData\Swyx\Traces


 


To get a better overview of a call within the traces (from a call routing perspective) this might help:


 


http://archive-swyx-forum.com/community/SwyxPEDIA/tabid/56/Default.aspx?topic=How+to+filter+the+Server+Trace+for+Call+Routing+ou

Share this post


Link to post
Share on other sites

All resolved thanks to the trace logs, internal numbers were trying to be routed through the ISDN and locally at the same time.  I just added a + sign in front of the * in the routing record for the ISDN and all is well.


 


Thank you for your help.


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now