Sign in to follow this  
tschaefer

Telekom Call& Surf Comfort All-Net

Recommended Posts

Moin !

 

Bin gerade dabei, den Zugang zum Telekom SIP zu konfigurieren.

 

Im KB Bereich von Swyx habe ich folgenden Hinweis gefunden:

 

 

Wichtiger Hinweis:
Die Deutsche Telekom betreibt an ihrem Call & Surf Anschluss zwei unterschiedlichen Plattformen (TAS und IMS), wobei nicht beantragt werden kann, an welcher Plattform der beauftragte Anschluss provisioniert werden soll.
Derzeit ist eine Anmeldung nur an der TAS Plattform möglich. Die SwyxWare kann sich nicht erfolgreich an der IMS Plattform anmelden.

 

 

Gilt die Aussage auch für SwyxWare2013 R4 ?

 

Ich weiss momentan nicht genau wo der Fehler ist, ob die Anmeldung wegen o.a. fehlschlägt oder ob meine Firewall noch stört.

Das LinkMgr Log erzeugt ca 20.000 Zeilen /Std - hier was zu finden ist fast unmöglich., vor allem wenn man nicht mal sicher ist, wonach man suchen soll.

 

Ich hab die Trunkgruppe mit dem Profil "Telekom Call and Surf(DE)" konfiguriert, in der Firewall habe ich die IP vom SwyxServer quasi schon komplett exposed für Verkehr von/zum Registrar+STUN Server.

 

Ich kann ein ständiges Auftreten dieser Fehler feststellen:

6 17:18:31.857 003a90 Info STUN       07FEF954 00000000 Validate                                () Validate, length=0 msgLength=826 17:18:31.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: SetQos=1 Addr=217.0.0.129 Port=347826 17:18:31.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: (restore) SetQos=1 Addr=217.0.23.100 Port=506026 17:18:31.857 003a90 Info STUN       07FEFAB4 00000000 Write                                   () Write action, handle=996 ok=1 bytes=2826 17:18:32.857 003a90 Info STUN       07FEFAA8 00000000 Read                                    () Read failed, handle=99626 17:18:32.857 003a90 Info STUN       07FEFAA8 00000000 SSTUNMessage::Poll                      () no success handle=99626 17:18:32.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::IsSTUNData                 () message type OK26 17:18:32.857 003a90 Info STUN       07FEF954 00000000 Validate                                () Validate, length=0 msgLength=826 17:18:32.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: SetQos=1 Addr=217.0.0.129 Port=347826 17:18:32.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: (restore) SetQos=1 Addr=217.0.23.100 Port=506026 17:18:32.857 003a90 Info STUN       07FEFAB4 00000000 Write                                   () Write action, handle=996 ok=1 bytes=2826 17:18:33.857 003a90 Info STUN       07FEFAA8 00000000 Read                                    () Read failed, handle=99626 17:18:33.857 003a90 Info STUN       07FEFAA8 00000000 SSTUNMessage::Poll                      () no success handle=99626 17:18:33.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::IsSTUNData                 () message type OK26 17:18:33.857 003a90 Info STUN       07FEF954 00000000 Validate                                () Validate, length=0 msgLength=826 17:18:33.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: SetQos=1 Addr=217.0.0.129 Port=347826 17:18:33.857 003a90 Inf3 STUN       007981F0 00000000 SSTUNSocket::WriteTo                    () STUN: (restore) SetQos=1 Addr=217.0.23.100 Port=506026 17:18:33.857 003a90 Info STUN       07FEFAB4 00000000 Write                                   () Write action, handle=996 ok=1 bytes=2826 17:18:34.857 003a90 Info STUN       07FEFAA8 00000000 Read                                    () Read failed, handle=99626 17:18:34.857 003a90 Info STUN       07FEFAA8 00000000 SSTUNMessage::Poll                      () no success handle=996

Danke

 

 

 

Share this post


Link to post
Share on other sites

Hm ok, hab nen Fehler gefunden und der Trunk ist jetzt aktiv.


 


Mein Fehler war das die Expire Zeit zu kurz war, stand von Swyxware voreingestellt auf 240 Sek, muss aber 3600 Sek sein.


Share this post


Link to post
Share on other sites

Neue Probleme:


 


1. Rufe kommen zwar an, werden also signalisiert, aber kein Gespräch baut sich auf, man hört den Partner nicht.


2. Rufen kommen an, aber im cdr0.txt ist erkennbar, das die ersten 3 Zeichen der Rufnummer abgeschnitten werden, also die +49 fehlt und der Anrufer erhält eine Ansage, das die Rufnummer nicht bekannt ist/bitte rufen Sie die Auskunft an.


 


Der Aufbau ist: Zyxel Speedlink -> Watchguard Firewall -> SwyxWare Server


 


Da noch ein 2. DSL Anschluss auf der Watchguard angebunden ist, kann es auch eine Firewall Regel sein, die nicht richtig greift.


 


Weiss jemand exakt, welche IPs und Ports die Telekom für ihre SIP Anbindung nutzt ?


Share this post


Link to post
Share on other sites

Hurra Problem ist wieder da !


 


~SIP/2.0 423 Interval Too Brief

~Via: SIP/2.0/UDP 84.153.217.181:65002;received=84.153.217.181;rport=65002;branch=z9hG4bK-d8754z-2d72df76704bf64e-1---d8754z-

~To: <sip:+498453332716@tel.t-online.de>;tag=puls2u57ufffil373jf2jew1g

~From: <sip:+498453332716@tel.t-online.de>;tag=047a8418

~Call-ID: M2ZiMmQyY2FkNjU2N2UzYjg2YzkyNmU3MmMxMmZhYTM.

~CSeq: 5937742 REGISTER

~Min-Expires: 480

~Content-Length: 0

 

Bekomme ich ständig, keine Rufe möglich.

 

Habe vom Standard 240 auf 480 und auch auf 3600 gesetzt - alles ist TOO BRIEF .....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this