gdixon

Sip Trunk Dtmf Duration

Recommended Posts

gdixon    0

Hi,

 

Can we manipulate the duration length of a DTMF tone that is sent over a SIP trunk?

 

I have applied the following regedits however it doesn't seem to be altering the length of the tones.

 

Navigate to HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Swyx > LinkMgr > CurrentVersion > Options
3. Right-Click and create a new ‘Key’ registry entry named:- GeneralLinkConfiguration
4. Right-Click ‘GeneralLinkConfiguration’ and select New > DWORD (32-Bit) Value. Name the new DWORD entry DTMFGapDuration
5. Set the DTMFGapDuration to 100
6. Right-Click ‘GeneralLinkConfiguration’ and select New > DWORD (32-Bit) Value. Name the new DWORD entry DTMFToneDuration
7. Set the DTMFGapDuration to 400
8. Right-Click ‘GeneralLinkConfiguration’ and select New > DWORD (32-Bit) Value. Name the new DWORD entry DTMFVolume
9. Set the DTMFGapDuration to 200

 

Cheers

post-136-0-94880900-1423671455_thumb.jpg

Share this post


Link to post
Share on other sites
Virikas    31

If you are on Swyx > 2011 R2 the registry key for this function has changed. You should get in contact with your reseller to get the new keys.


 


If you are on Swyx 2013 > R6 the new keys introduced do not work. That bug was fixed in R6.


Share this post


Link to post
Share on other sites
gdixon    0

Thanks,


 


This system is running on Swyx 2015.


 


Can you let me know what the registry keys are for this?


 


Thanks


 


Regards Graham


Share this post


Link to post
Share on other sites
Virikas    31

Nope, we got them directly from the support team and I'm not sure whether they want to see them publicitly posted. Sorry.


Share this post


Link to post
Share on other sites
Torsten    2

Hello,

 

the settings in registry works well in Swyx 2015 R2.

You can just test it with restart the service "SwyxLinkManager" (LinkMgr).

In our case we need 800 by DTMFTonDuration.

 

Thank you

Torsten

Share this post


Link to post
Share on other sites
Torsten    2

Hello,

 

two weeks ago we installed last update SwyxWare 2015 R40.3.0.

Now the DTMF dosen't work ;-)

Support said that the Key "DTMFVolume" has changed

In Version R2 was "200" the default, know are 00000007 is default (00000006 or 00000005 are louder)

Finaly you can work without the Keys "DTMFVolume" and "DTMFGapDuration".... use just the Key "DTMFTonDuration"

 

Regards,

Torsten

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now