Jump to content
Lars Heinrich

Voicemail Fernabfrage nicht möglich - Falsche Zugangsparameter

Recommended Posts

Moin zusammen.

 

Ich bin neu hier im Forum und habe durch bisheriges Googeln und auch suchen hier im Forum immer nur Teilantworten auf unser aktuelles Problem gefunden, die bislang nicht zu einer Lösung geführt haben.

 

Unsere Installation beinhaltet einen NetPhone Server Version 10.40.2513 (installiert auf einer Windows Server 2012 R2 VM) und einen Exchange 2019.

Für die Dienste des NetPhone Servers wurde im AD ein eigener User namens NetPhone erstellt.

Es gibt nur einen AB der an der Zentrale. Dieser wird auch von nur einer Nebenstelle abgefragt (Fernabfrage). Der IMAP Zugriff auf den Exchange wurde getestet und funktioniert.

 

Wenn ich nun unter den "Eigenschaften des Benutzers -> Einstellungen -> Umleitungen -> Standard-Fernabfrage"  unseren Mailserver per FQDN, den Benutzernamen "NetPhone" und sein AD Passwort sowie als Mailordner "INBOX" angebe kann ich ohne Probleme die Voicemails im Posteingang des Users NetPhone abfragen.

 

Unser Ziel ist aber die Voicemails in einem erstellten Ordner namens "Voicemail" in einer SharedMailbox des Exchange auflaufen zu lassen und dort abzufragen.
Für alle die es nicht wissen, eine SharedMailbox ist nicht an einen AD User gebunden sondern Benutzer können auf dieses Postfach berechtigt werden (read/write/full/uvm.).

Sobald wir dem User NetPhone das Recht "Prüfer" (nur lesen) auf den Ordner in der SharedMailbox geben und die Anmeldeparameter anpassen bekommen wir die Fehlermeldung "Auf Ihr Postfach kann nicht zugegriffen werden. Bitte überprüfen Sie Ihre Zugangsparameter."
Zum Abgleich haben wir über den ebenfalls vorhandenen TerminalServer Outlook unter dem User NetPhone gestartet und bekommen den Ordner Voicemail der SharedMailbox angezeigt und wir dürfen die Mails in dem Ordner auch einsehen/lesen.

 

Hat jemand bereits eine solche Installation am laufen und kann mir Tipps geben wie genau das ganze einzurichten ist?

Nach unserem Verständnis muss das Benutzerkonto in der Standard-Fernabfrage des NetPhone-Server-Benutzers wie eine IMAP Anmeldung eingerichtet werden. Das heißt unsere Anmeldung müsste lauten "netphone@domain\sharedmailbox@domain.de" und da der Ordner Voicemail sich auf der gleichen Ebene wie die INBOX befindet auch nur "Voicemail" als Mail-Ordner-Bezeichnung.

 

Ich bin gespannt wer helfen kann.

Vielen Dank schon einmal im voraus.

 

EDIT: Dem User "NetPhone" wurden auch die Rechte des "Besitzers" auf den Ordner der Shared Mailbox gegeben um ein Rechteproblem auszuschließen.

 

Edited by Lars Heinrich

Share this post


Link to post
Share on other sites
1 hour ago, Lars Heinrich said:

Sobald wir dem User NetPhone das Recht "Prüfer" (nur lesen) auf den Ordner in der SharedMailbox geben

 

aus Exchange-Sicht kann ich Dir leider gar nicht helfen. Aber was mich stutzig macht, ist das "nur lesen"-Recht, denn die Swyx möchte auch Nachrichten als gelesen markieren (wenn sie abgehört wurden) oder löschen (wenn sie per Fernabfrage gelöscht werden) - vielleicht ist dieses Recht also zu wenig und es scheitert daran?

 

Was ist denn, wenn Du mit irgend einem IMAP-Client mit diesen Zugangsdaten eine Verbindung öffnest - kommst Du dann an den Wunschordner ran?

Share this post


Link to post
Share on other sites
25 minutes ago, jodost said:

 

aus Exchange-Sicht kann ich Dir leider gar nicht helfen. Aber was mich stutzig macht, ist das "nur lesen"-Recht, denn die Swyx möchte auch Nachrichten als gelesen markieren (wenn sie abgehört wurden) oder löschen (wenn sie per Fernabfrage gelöscht werden) - vielleicht ist dieses Recht also zu wenig und es scheitert daran?

 

Was ist denn, wenn Du mit irgend einem IMAP-Client mit diesen Zugangsdaten eine Verbindung öffnest - kommst Du dann an den Wunschordner ran?

 

Hey jodost und danke für die schnelle Rückmeldung.

 

Vergessen hinzuzufügen, dass wir dem User auch das Recht "Besitzer", also Vollzugriff gegeben und getestet haben mit leider gleichem Ergebnis/Fehler.

 

Wenn ich das Konto als IMAP in Outlook einrichte ist alles super. :-/ mhh..

Share this post


Link to post
Share on other sites

So, es ist etwas her und entschuldigt das Schweigen, aber die Arbeit wartet nie :D

Wir haben das ganze nun erst einmal anders gelößt.

Wir haben der SharedMailbox über das AD ein Passwort gegeben (Den deaktivierten User vorher natürlich aktiviert) und haben diese Credentials dann für die Abfrage auf die SharedMailbox genutzt.

Das funktioniert super.

 

Als nächsten Step darf sich der Telekom Support an der Hotline um eine Antwort bemühen und mir mitteilen, wieso ich nicht die Abfrage auf das Postfach mittels eines berechtigten Users und per IMAP nicht ausführen kann/darf.
Sobald ich dazu eine Antwort habe teile ich diese gerne mit Euch =)!

Dennoch vielen Dank für eure schnelle Hilfe!

Lg Lars

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×