Jump to content
Kostas

Rufnummernübermittlung, es wird NUR die Zentrale übertragen und nicht die NS

Recommended Posts

Hallo Zusammen,

 

ich habe das Problem das die bei ausgehenden Anrufen nicht die komplette Rufnummer incl. Nebenstelle übertragen wird sondern immer nur die Zentrale.

-In der Adminkonsole ist bei den Benutzern zu sehen das die Rufnummernunterdrückung NICHT gesetzt ist, siehe Bild.

-Im Trunk ist ebenfalls zu sehen dass "Rufnummer des Anbieters signalisieren" gesetzt ist, siehe Bild.

-Im NetPhoneClient ist ebenfalls zu sehen dass die Rufnummern unterdrückung nicht aktiv ist, siehe Bild.

 

Eine Nachfrage bei Carrier ob möglicherweise Er die Rufnummer unterdrückt hat folgendes ergeben:

bei DDI Profil Swyx muss bei abgehenden Gesprächen die komplette Rufnummer, nicht nur die DuWa! im User in SIP Request's P-Preferred-Identity header in der Anlage eingetragen sein.
Beispiel: P-Preferred-Identity: <sip:08912345@voip1.dslmobil.de;user=phone> dies wird aktuell an uns nicht übergeben.

 

Hat jemand eine Idee wo das einzutragen ist?

 

Der Support kann mir nicht helfen weil es eine Telekom Anlage ist ich keine Support Support bei Swyx habe. Bei Telekom habe ich bereits ein Ticket eröffnet doch das kann mindestens eine Woche dauern bis mein Ticket bearbeitet wird. Unser Telekom Verkäufer der Anlage sagt, es geht nur über die Geschäftskundenhotline oder Techniker kommt vor Ort. Seit zwei Wochen schlage ich mich mit dem Thema herum und komme einfach nicht weiter.

 

Meine Hoffnung ist, das jemand im Forum dieses Problem kennt und mir sagen kann was ich falsch mache. 

 

Leider kann ich die screen shots nicht übertragen. Wenn sie notwendig sind, müsste ich einen anderen Weg suchen.

 

Gruß Kostas

 

 

 

 

Share this post


Link to post
Share on other sites

Hallo srom,

 

sorry dass ich jetzt erst antworte, ich habe keine Benachrichtigung erhalten. 

 

Ich habe die NetPhone Administration gestartet./Trunks/Gruppeneigenschaften/Profil. Das Profil steht auf SIP (angepasst) bei:

Nummerformatierung Konvertierung für ausgehende Rufe:

Anrufnummer und Zielrufnummer stehen beide auf  "National"

Ebenso bei Konvertierung für ankomende Rufe bei  unbek. Rufnummerntyp:

Anrufnummer und Zielrufnummer stehen beide auf  "National"

 

Alle vier Einträge habe ich auch auf "Teilnehmernummer" gestellt und die Anlege neu gestartet, bringt nichts.

 

Meintest du das?

Gruß Kostas

 

 

 

Share this post


Link to post
Share on other sites

Puhh...eventuell setzt dein Profil auch das P-Preferred nicht richtig.

Müsste man in Wireshark mal anschauen was der Server wirklich nach Extern sendet, zumindest finde ich mich da immer schneller zurecht.

 

Probier doch mal eine Rufnummernersetzung

 

Gehende Anrufernummer

+494711815* nach 04711815*

 

 

Share this post


Link to post
Share on other sites

Hallo srom,

 

ich kann leider nicht eintragen. Das sind DropDown Felder. Oder wird für das Profil jeweils eine Datei angelegt die ich editieren kann? Wenn ja, wo könnte diese Datei liegen, nach was müsste ich suchen?

 

[EDIT] ich habe über das DropDown Eingestellt Kanonisch ohne + auf alle vier Bereiche. Wenn ich versuche von einer Nebenstelle mein Handy anzurufen und geben die Nummer 00175... (die erste 0 für das Amt) bekomme ich die Meldung keine gültige Rufnummer/URI

 

Gruß Kostas

 

Edited by Kostas

Share this post


Link to post
Share on other sites

Ja auf der Eigenschaften Seite des Profils gibt es "Spezielle Rufnummernersetzungen"

Share this post


Link to post
Share on other sites

Genau das habe ich auch so. Das Erste Bild mit dem Beispiel +492314777 das ist bei mir alles komplett leer.

Ich werde jetzt mal bei Konvertieren für ausgehende Rufe aus dem Drop Down alle Einträge ausprobieren ob irgend eines dabei ist das funktioniert. 

Kann es noch eine Ursache haben?

Share this post


Link to post
Share on other sites

Leider ohne Erfolg. Ich habe alle Einträge aus der DropDown ausprobiert.

2019-03-01_181215.png

Share this post


Link to post
Share on other sites

Du sollst unten auf "Konfigurieren" klicken und dann siehst du das Fenster und dann eben die gehende Anrufernummer ersetzen wie ich oben geschrieben habe;0)

Share this post


Link to post
Share on other sites

Auf die Gefahr hin dass ich jetzt gesteinigt werden,

es tut mir schrecklich leid aber ich checks einfach nicht. 😞 

Du hast sicherlich mein Fehler erkannt. Du schreibt, ich soll auf Konfigurieren klicken und die Nummer ersetzen. Warum muss ich die Rufnummer ersetzten von wo nach wo?

Angenommen meine Rufnummer wäre 089 123456-0 dann soll ich ersetzen +4989123456* nach wohin? Ich habe keine Sub-PBX wie es dran steht. Mein Problem ist nur die ausgehende Rufnummer 089 123456-14

wird angezeigt als Zentrale also 0891234560 und nicht 08912345614  bzw. +49891234560 und nicht +498912345614

 

Bitte um Vergebung wenn ich nicht verstehe was du mir die ganze Zeit sagen möchtest. 😞

 

Gruß Kostas

Share this post


Link to post
Share on other sites

Du schreibst rein +498912345* nach 08912345*

Der Stern dient als Wildcard..theoretisch könntest du auch +4989* nach 089* machen

 

Gehende Anrufnummer...wenn es nix bringt löscht du den Eintrag einfach wieder.

Dü könntest damit z.b. sagen

 

+498912345-1* nach +498912345-0

damit würden alle 1xx Durchwahlen die -0 Signalisieren.

 

Hier der Beitrag...

 

Share this post


Link to post
Share on other sites

Jetzt verstehe ich den Sinn. 

ich habe bei Ausgehende Anrufnummern versucht:

+89123456* nach 089123456*

und

089123456* nach +4989123456*

bring leider auch nichts. Im Teledata Beitrag ist die Rede von einer CustomProfil als xml file. Wo bitte sind diese Files abgelegt. Möglicherweise kann man daraus mehr erkennen.

Ich habe übrigens auch die vordefinierten Profile der deutschen Provider ausprobiert, hat leider auch nichts gebracht. 

 

Im Trunk/Rufnummer habe ich zwei Einträge:

Landeskennzahl   Ortskennzahl  Rufnummer/MSN

49                           89                      12345610-12345629   //Nummernblock 10-29

49                           89                      1234560                        //Zentrale

 

Im Trunk/SIP-URIs:

Benutzername Realm:

*                         IP-Adresse:Port

 

Im Trunk/Rufnummernsignalisierung:

Rufnummer des Anrufers signalisieren

 

Im Trunk/Codecs/Kanäle

alle Codecs sind aktiv

 

Herzlichen Dank für deinen Einsatz!!!

 

 

 

Share this post


Link to post
Share on other sites

Hilft leider alles nichts. Vermutlich ist das Problem wo anders. 

Ich hatte gehofft, die Einstellungen meines Profils in   ProviderProfiles.config zu finden um weitere Details zu erfahren. Doch mein Eintrag ist nicht vorhanden. Es gibt auch keine CustomProviderProfiles.config die muss man wahrscheinlich selbst anlegen die es im Dokument steht. Ich muss jetzt einfach warten bis sich die Telekom bei mir meldet. Wahrscheinlich werden die mich kontaktieren wenn ich gerade kein Zugriff auf das System habe und dann muss ich wieder warten. Die Anwender werden schon ungeduldig.

 

Ein herzliches Dankeschön srom. Sobald ich in Erfahrung gebracht habe was die Ursache ist, werde ich die Lösung hier veröffentlichen.

 

Gruß Kostas  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×