Jump to content
Sign in to follow this  
Ralf St

Swyx Mobile Offline

Recommended Posts

Hallo

 

Wenn ich Swyx Mobile 2015 mittels externem Server, also mit ausgeschaltetem WLAN nutzen möchte, erscheint die Meldung: Sie sind Offline.

 

Meine Konfiguration ist folgende:

Betriebssystem Microsoft Windows Server 2012 R2 Standard

Netphone Version 10.40.2694 de-DE

 

Unter Eigenschaften von Netphone Server, RemoteConnector, Remotezugriff aktiviert und sowohl bei Authentifizierungsserver als auch Remote Connector Server entweder Server Namen oder lokale Serveradresse eingetragen

 

Unter Benutzer, Eigenschaften, Umleitungen, Mobile Erweiterungen, Mobile Erweiterungen verwenden aktiviert und sowohl unter Nummer des Mobiltelefons als auch Anrufernummer/Mobile ID die Nummer des Mobiltelefons in kanonischer Form eingegeben

 

Am Router sowohl für den Port 9101 als auch 16203 eine TCP Portfreigabe für den Netphone Server mit der lokalen Serveradresse eingegeben

 

IOS Version des iPhones IOS 11.4.1

 

Am Mobiltelefon in der APP Swyx Mobile 2015 die Server Variante SwyxWare/Octopus Netphone ausgewählt, als internen Server die lokale Serveradresse eingegeben und als externen Server entweder meine No-IP Adresse oder die aktuelle Internet Adresse des Routers eingegeben.

Als Benutzername und Kennwort die Daten des gewünschten Benutzers eingegeben.

 

Befinde ich mich im heimischen WLAN funktioniert die APP.

Unter Benutzer, Eigenschaften, Endgeräte ist das Mobiltelefon/IPhone aufgeführt.

 

Bei ausgeschaltetem WLAN und somit im LTE Netz kommt keine Verbindung zu Stande. Als Fehlermeldung erscheint: Sie sind Offline oder Verbindung zum Server fehlgeschlagen. Zeitüberschreitung bei der Anforderung. Entweder nach mehrmaliger Aktualisierung oder Neustart des Servers ist dann auch unter Benutzer, Eigenschaften, Endgeräte das Mobiltelefon nicht mehr aufgeführt.

 

Auch Windows Firewall versuchsweise komplett ausgeschaltet.

 

Was mich ich da noch falsch ?

 

Habe alle Vorschläge im Forum ohne Erfolg ausprobiert

Share this post


Link to post
Share on other sites

Generell wenn ich die APP neu installiere bzw. beim ersten Start im WLAN kommt folgende Meldung: Unbekanntes Server Zertifikat, Trotzdem annehmen.

 

Die nehme ich dann an. Dann ist Verbindung im WLAN möglich.

 

Diese Meldung kommt ob ich ein User Zertifikat erstellt habe oder nicht.

 

Auch wenn ich ein User Zertifikat erstellt habe, ist trotzdem keine Verbindung bei ausgeschaltetem WLAN und somit im LTE Netz möglich.

 

Was muss ich denn mit dem User Zertifikat machen. Es noch irgend wo hin kopieren bzw. installieren ?

Share this post


Link to post
Share on other sites

Das sollte eigentlich bei der Wlan Verbindung übermittelt werden und das legt das Handy dann im Speicher ab.

 

Ich prüfe das gerne mit Wireshark auf dem Server.

Da sieht man schnell ob auf 9101 und 16203 überhaupt Anfragen ankomme .

Share this post


Link to post
Share on other sites

So Problem gelöst.

Hier auch für die anderen Verzweifelten.

 

In der Netphone Administration am Server unter Eigenschaften, Remote Connector den Remote Zugriff aktivieren. 

Bei Authentifizierungsserver die statische öffentliche IP Adresse bzw. eine DynDNS Adresse und Port 9101 eintragen.

Bei RemoteConnectorServer ebenfalls die statische öffentliche IP Adresse bzw. eine DynDNS Adresse und Port 16203 eintragen.

 

In der Netphone Administration unter dem jeweiligen Benutzer unter Eigenschaften, Administration, Remote Connector unter Automatisch erstelltes Zertifikat verwenden mit Neu ein solches erstellen.

 

Das Zertifikat wird bei erstem Einloggen im WLAN automatisch an die App übertragen.

 

Am Router Portfreigaben für die Anwendung HTTPS Server mit Protokoll TCP für jeweils die Ports 9101 und 16203 erstellen.

 

Als App die Swyx Mobile 2015 herunterladen.

 

In der App unter Einstellungen als Interner Server die lokale IP Adresse, als Externer Server die statische öffentliche IP Adresse bzw. eine DynDNS Adresse, den Benutzernamen des gewünschten Benutzers und dessen Kennwort eingeben.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×